Click or drag to resize

GH_ComponentGH_OutputParamManagerRegister_GeometryParam Method (String, String, String, GH_ParamAccess)

Register a new 3D geometry parameter

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public void Register_GeometryParam(
	string name,
	string nickname,
	string description,
	GH_ParamAccess access
)

Parameters

name
Type: SystemString
The name of the parameter. Keep it short, single words are best.
nickname
Type: SystemString
The nickname of the parameter. Keep it short, single characters are best.
description
Type: SystemString
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.KernelGH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.
See Also