Click or drag to resize

GH_DocumentObjectRecordUndoEvent Method (String)

Record a generic object change undo event.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public Guid RecordUndoEvent(
	string undoName
)

Parameters

undoName
Type: SystemString
Name of undo record.

Return Value

Type: Guid
The ID of the newly added record or Guid.Empty on failure.

Implements

IGH_DocumentObjectRecordUndoEvent(String)
See Also