Click or drag to resize

GH_Item Methods

The GH_Item type exposes the following members.

Methods
  NameDescription
Public methodStatic memberCreateFrom(BinaryReader)
Creates a new instance of GH_Item and sets the fields from a reader object.
Public methodStatic memberCreateFrom(XmlNode)
Creates a new instance of GH_Item and sets the fields from an Xml node object.
Public methodRead(BinaryReader)
Deserialize this item from a binary stream.
Public methodRead(XmlNode)
Deserialize this item from an Xml node.
Public methodToString
Converts the struct into a human readable format.
(Overrides ObjectToString.)
Public methodWrite(BinaryWriter)
Serialize this item into a binary stream.
Public methodWrite(XmlWriter)
Serialize this item into an Xml stream.
Top
See Also