Click or drag to resize

GH_Curve Properties

The GH_Curve type exposes the following members.

Properties
  NameDescription
Public propertyBoundingbox (Overrides GH_GeometricGooTBoundingbox.)
Public propertyClippingBox
Public propertyIsGeometryLoaded
Gets the load state of this curve object. The curve is considered to be loaded when the local OnCurve instance is not null.
(Overrides GH_GeometricGooTIsGeometryLoaded.)
Public propertyIsValid
Gets the validity of this curve. If the curve is referenced but cannot be loaded, the curve is not valid.
(Overrides GH_GeometricGooTIsValid.)
Public propertyIsValidWhyNot
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.)
Public propertyReferenceEdge
Gets or sets the edge index for a referenced curve. If the index >= 0 then an edge reference is implied.
Public propertyReferenceID (Overrides GH_GeometricGooTReferenceID.)
Public propertyTypeDescription (Overrides GH_GooTTypeDescription.)
Public propertyTypeName (Overrides GH_GooTTypeName.)
Public propertyValue (Overrides GH_GeometricGooTValue.)
Top
See Also