Click or drag to resize

GH_UndoRecord Properties

The GH_UndoRecord type exposes the following members.

Properties
  NameDescription
Public propertyActionCount
Gets the number of actions stored in this record.
Public propertyActions
Gets or sets the actions inside this record.
Public propertyExpiresDisplay
Gets the display expiration flag for this event. If True, the Rhino viewports will be redrawn once the entire undo record has been completed. If ExpiresSolution is set to true, ExpriresDisplay is implied.
Public propertyExpiresSolution
Gets the solution expiration flag for this event. If True, the solution needs to be recalculated once the entire undo record has been completed.
Public propertyGuid
Gets the ID of this undo item. Every undo record has a unique ID.
Public propertyName
Gets or sets the name of the undo record (as displayed in the menu)
Public propertyState
Gets the undo state of this record. The state dictates which action are legal.
Public propertyTime
Gets the time at which this record was created.
Top
See Also