Click or drag to resize

GH_DocumentRenderMeshProvider Class

Utility class for seeding render queues with GH geometry.
Inheritance Hierarchy
SystemObject
  CustomRenderMeshProvider
    CustomRenderMeshProvider2
      Grasshopper.KernelGH_DocumentRenderMeshProvider

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_DocumentRenderMeshProvider : CustomRenderMeshProvider2

The GH_DocumentRenderMeshProvider type exposes the following members.

Constructors
  NameDescription
Public methodGH_DocumentRenderMeshProvider
Initializes a new instance of the GH_DocumentRenderMeshProvider class
Top
Properties
  NameDescription
Public propertyName (Overrides CustomRenderMeshProvider.Name.)
Top
Methods
  NameDescription
Public methodBoundingBox(ViewportInfo, RhinoObject, RhinoDoc, Guid, DisplayPipelineAttributes) (Overrides CustomRenderMeshProvider2.BoundingBox(ViewportInfo, RhinoObject, RhinoDoc, Guid, DisplayPipelineAttributes).)
Public methodBuildCustomMeshes(ViewportInfo, RhinoDoc, RenderPrimitiveList, Guid, DisplayPipelineAttributes) (Overrides CustomRenderMeshProvider2.BuildCustomMeshes(ViewportInfo, RhinoDoc, RenderPrimitiveList, Guid, DisplayPipelineAttributes).)
Public methodWillBuildCustomMeshes(ViewportInfo, RhinoObject, RhinoDoc, Guid, DisplayPipelineAttributes) (Overrides CustomRenderMeshProvider2.WillBuildCustomMeshes(ViewportInfo, RhinoObject, RhinoDoc, Guid, DisplayPipelineAttributes).)
Top
See Also