Click or drag to resize

GH_StateTag Class

Abstract implementation of the IGH_StateTag interface. Derive from this class rather than implementing IGH_StateTag.
Inheritance Hierarchy
SystemObject
  Grasshopper.KernelGH_StateTag

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public abstract class GH_StateTag : IGH_StateTag

The GH_StateTag type exposes the following members.

Constructors
  NameDescription
Protected methodGH_StateTag
Initializes a new instance of the GH_StateTag class
Top
Properties
  NameDescription
Public propertyDescription
Public propertyIcon
Public propertyName
Public propertyStage
Gets or sets the stage rectangle for this tag.
Public propertyStateDescription
Gets or sets the state description for this tag.
Top
Methods
  NameDescription
Public methodRender
Protected methodRenderFreeformIcon
Render a filled path with default shading.
Protected methodRenderTagBlankIcon(Graphics)
Render a blank rectangle icon.
Protected methodRenderTagBlankIcon(Graphics, GH_StateTagDrawCallback)
Render a blank rectangle icon.
Protected methodRenderTagPolygonIcon
Render a filled polygon with default shading.
Top
See Also