Click or drag to resize

GH_StateTagList Class

Maintains a collection of IGH_StateTag objects.
Inheritance Hierarchy
SystemObject
  System.Collections.GenericListIGH_StateTag
    Grasshopper.KernelGH_StateTagList

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_StateTagList : List<IGH_StateTag>, 
	IGH_TooltipAwareObject

The GH_StateTagList type exposes the following members.

Constructors
  NameDescription
Public methodGH_StateTagList
Initializes a new instance of the GH_StateTagList class
Top
Properties
  NameDescription
Public propertyBoundingBox
Gets the boundingbox of all StateTags.
Top
Methods
  NameDescription
Public methodLayout
Layout the StateTags.
Public methodRenderStateTags
Render all StateTags in this list to the designated Graphics surface.
Top
See Also