Click or drag to resize

IGH_TypeHint Interface

Represents conversion logic for a certain data type.

Namespace:  Grasshopper.Kernel.Parameters
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public interface IGH_TypeHint

The IGH_TypeHint type exposes the following members.

Properties
  NameDescription
Public propertyHintID
Unique ID for every type of Hint.
Public propertyTypeName
Name of target Type
Top
Methods
  NameDescription
Public methodCast
Apply conversion logic to a specific object. This function should not throw exceptions.
Top
See Also