GH_AnnotationBase Class |
Namespace: Grasshopper.Kernel.Types
The GH_AnnotationBase type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_AnnotationBase |
Default constructor, creates an invalid annotation.
|
![]() | GH_AnnotationBase(AnnotationBase) |
Create a duplicate of an existing annotation.
|
![]() | GH_AnnotationBase(GH_AnnotationBase) |
Create a duplicate of another GH_AnnotationBase. This constructor also copies reference data.
|
![]() | GH_AnnotationBase(Guid) |
Create a new referenced annotation that references a Rhino dimension with the specified ID.
|
![]() | GH_AnnotationBase(ObjRef) | Initializes a new instance of the GH_AnnotationBase class |
![]() | GH_AnnotationBase(AnnotationBase, ModelAnnotationStyle) |
Create a duplicate of an existing annotation.
|
Name | Description | |
---|---|---|
![]() | Boundingbox | (Overrides GH_GeometricGooTBoundingbox.) |
![]() | ClippingBox | |
![]() | IsGeometryLoaded |
Gets the load state of this annotation object. The annotation is considered to be loaded when the local annotation instance is not null.
(Overrides GH_GeometricGooTIsGeometryLoaded.) |
![]() | IsReferencedGeometry |
Gets a value indicating whether or not this geometry is referenced.
Not all IGH_GeometricGoo implementations support referenced geometry.
(Inherited from GH_GeometricGooT.) |
![]() | IsValid |
Gets the validity of this dimension. If the dimension is referenced but cannot be loaded, then the dimension is not valid.
(Overrides GH_GeometricGooTIsValid.) |
![]() | IsValidWhyNot |
Gets a string describing the state of "invalidness".
If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.) |
![]() | ReferenceID | (Overrides GH_GeometricGooTReferenceID.) |
![]() | Style | |
![]() | TypeDescription | (Overrides GH_GooTTypeDescription.) |
![]() | TypeName | (Overrides GH_GooTTypeName.) |
![]() | Value |
Gets or sets the value of this type.
Note that if the type has a ReferenceID this value might get destroyed in the future.
(Inherited from GH_GeometricGooT.) |
![]() | ValueType |
Name | Description | |
---|---|---|
![]() | BakeGeometry | |
![]() | CastFrom |
Attempt a cast from generic object.
(Inherited from GH_GeometricGooT.) |
![]() | CastToT(T) |
Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GeometricGooTCastToQ(Q).) |
![]() | CastToQ(Q) |
Attempt a cast to type T.
(Inherited from GH_GeometricGooT.) |
![]() | CastToQ(Q) |
Attempt a cast to type Q.
(Inherited from GH_GooT.) |
![]() | ClearCaches |
Clears all volatile caches for this instance. The boundingbox is cleared, and if the annotation is referenced,
the local instance of the annotation is erased.
(Overrides GH_GeometricGooTClearCaches.) |
![]() ![]() | CreateDisplay | |
![]() | DrawViewportMeshes | |
![]() | DrawViewportWires | |
![]() | Duplicate | (Overrides GH_GeometricGooTDuplicate.) |
![]() | DuplicateAnnotation |
Create a duplicate of this annotation.
|
![]() | DuplicateGeometry |
Create a duplicate of this annotation.
(Overrides GH_GeometricGooTDuplicateGeometry.) |
![]() | EmitProxy |
Create a new proxy for this instance. Return Null if this class does not support proxies.
(Inherited from GH_GeometricGooT.) |
![]() | GetBoundingBox | (Overrides GH_GeometricGooTGetBoundingBox(Transform).) |
![]() | GetOverrides | |
![]() | LoadGeometry |
If the geometry is referenced and not yet loaded, attempts to load the geometry.
(Overrides GH_GeometricGooTLoadGeometry.) |
![]() | LoadGeometry(RhinoDoc) |
If the annotation is referenced and not yet loaded, attempts to load the leader.
(Overrides GH_GeometricGooTLoadGeometry(RhinoDoc).) |
![]() | Morph | (Overrides GH_GeometricGooTMorph(SpaceMorph).) |
![]() | Read | (Overrides GH_GooTRead(GH_IReader).) |
![]() | ScriptVariable | (Overrides GH_GooTScriptVariable.) |
![]() | SetOverrides | |
![]() | ToString |
Format the dimension using default grasshopper formatting logic.
(Overrides GH_GooTToString.) |
![]() | Transform | (Overrides GH_GeometricGooTTransform(Transform).) |
![]() | Write | (Overrides GH_GooTWrite(GH_IWriter).) |