GH_PointCloud Class |
Namespace: Grasshopper.Kernel.Types
The GH_PointCloud type exposes the following members.
Name | Description | |
---|---|---|
GH_PointCloud |
Default constructor, creates an invalid curve.
| |
GH_PointCloud(GH_PointCloud) |
Create a duplicate of another GH_PointCloud. This constructor also copies reference data.
| |
GH_PointCloud(Guid) |
Create a new referenced curve that references a Rhino curve object with the specified ID.
| |
GH_PointCloud(PointCloud) |
Create a duplicate of an existing point-cloud.
|
Name | Description | |
---|---|---|
Boundingbox | (Overrides GH_GeometricGooTBoundingbox.) | |
ClippingBox | ||
IsGeometryLoaded |
Gets the load state of this curve object. The curve is considered to be loaded when the local OnCurve instance is not null.
(Overrides GH_GeometricGooTIsGeometryLoaded.) | |
IsReferencedGeometry |
Gets a value indicating whether or not this geometry is referenced.
Not all IGH_GeometricGoo implementations support referenced geometry.
(Inherited from GH_GeometricGooT.) | |
IsValid |
Gets the validity of this curve. If the curve is referenced but cannot be loaded, the curve is not valid.
(Overrides GH_GeometricGooTIsValid.) | |
IsValidWhyNot |
Gets a string describing the state of "invalidness".
If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.) | |
ReferenceID | (Overrides GH_GeometricGooTReferenceID.) | |
TypeDescription | (Overrides GH_GooTTypeDescription.) | |
TypeName | (Overrides GH_GooTTypeName.) | |
Value | (Overrides GH_GeometricGooTValue.) |
Name | Description | |
---|---|---|
BakeGeometry | ||
CastFrom |
Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GeometricGooTCastFrom(Object).) | |
CastToQ(Q) |
Attempt a cast to type T.
(Inherited from GH_GeometricGooT.) | |
CastToQ(Q) |
Attempt a cast to type Q.
(Inherited from GH_GooT.) | |
CastToT(T) |
Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GeometricGooTCastToQ(Q).) | |
ClearCaches |
Clears all volatile caches for this instance. The boundingbox is cleared, and if the curve is referenced,
the local instance of the curve is erased.
(Overrides GH_GeometricGooTClearCaches.) | |
DrawViewportMeshes | ||
DrawViewportWires | ||
Duplicate | (Overrides GH_GeometricGooTDuplicate.) | |
DuplicateGeometry |
Create a duplicate of this curve.
(Overrides GH_GeometricGooTDuplicateGeometry.) | |
DuplicatePointCloud |
Create a duplicate of this curve.
| |
EmitProxy |
Create a new proxy for this instance. Return Null if this class does not support proxies.
(Inherited from GH_GeometricGooT.) | |
GetBoundingBox | (Overrides GH_GeometricGooTGetBoundingBox(Transform).) | |
LoadGeometry |
If the geometry is referenced and not yet loaded, attempts to load the geometry.
(Overrides GH_GeometricGooTLoadGeometry.) | |
LoadGeometry(RhinoDoc) |
If the curve is referenced and not yet loaded, attempts to load the curve.
(Overrides GH_GeometricGooTLoadGeometry(RhinoDoc).) | |
Morph | (Overrides GH_GeometricGooTMorph(SpaceMorph).) | |
Read | (Overrides GH_GooTRead(GH_IReader).) | |
ScriptVariable | (Overrides GH_GooTScriptVariable.) | |
ToString |
Format the curve using default grasshopper formatting logic.
(Overrides GH_GooTToString.) | |
Transform | (Overrides GH_GeometricGooTTransform(Transform).) | |
Write | (Overrides GH_GooTWrite(GH_IWriter).) |