Namespace: Rhino.CollectionsCurveList: references
CurveList()
CurveList(IEnumerable<Curve> collection)
CurveList(int initialCapacity)
RhinoList<T>()
RhinoList<T>(IEnumerable<T> collection)
RhinoList<T>(int amount, T defaultValue)
RhinoList<T>(int initialCapacity)
RhinoList<T>(RhinoList<T> list)
Capacity
Count
First
Item
Last
NullCount
Add(Arc arc)
Add(Circle circle)
Add(Ellipse ellipse)
Add(IEnumerable<Point3d> polyline)
Add(Line line)
Add(T item)
AddRange(IEnumerable<T> collection)
AddRange(IEnumerable collection)
AsReadOnly()
BinarySearch(int index, int count, T item, IComparer<T> comparer)
BinarySearch(T item, IComparer<T> comparer)
BinarySearch(T item)
Clear()
Contains(T item)
ConvertAll(Converter<T, TOutput> converter)
CopyTo(int index, T[] array, int arrayIndex, int count)
CopyTo(T[] array, int arrayIndex)
CopyTo(T[] array)
Duplicate()
Exists(Predicate<T> match)
Find(Predicate<T> match)
FindAll(Predicate<T> match)
FindIndex(int startIndex, int count, Predicate<T> match)
FindIndex(int startIndex, Predicate<T> match)
FindIndex(Predicate<T> match)
FindLast(Predicate<T> match)
FindLastIndex(int startIndex, int count, Predicate<T> match)
FindLastIndex(int startIndex, Predicate<T> match)
FindLastIndex(Predicate<T> match)
ForEach(Action<T> action)
GetEnumerator()
GetRange(int index, int count)
IndexOf(T item, int index, int count)
IndexOf(T item, int index)
IndexOf(T item)
Insert(int index, Arc arc)
Insert(int index, Circle circle)
Insert(int index, Ellipse ellipse)
Insert(int index, IEnumerable<Point3d> polyline)
Insert(int index, Line line)
Insert(int index, T item)
InsertRange(int index, IEnumerable<T> collection)
LastIndexOf(T item, int index, int count)
LastIndexOf(T item, int index)
LastIndexOf(T item)
RemapIndex(int index)
Remove(T item)
RemoveAll(Predicate<T> match)
RemoveAt(int index)
RemoveNulls()
RemoveRange(int index, int count)
Reverse()
Reverse(int index, int count)
Sort()
Sort(Comparison<T> comparison)
Sort(double keys)
Sort(IComparer<T> comparer)
Sort(int index, int count, IComparer<T> comparer)
Sort(int keys)
ToArray()
Transform(Transform xform)
TrimExcess()
TrueForAll(Predicate<T> match)