Description:

Repeats an operation of a command. In order to make this function work, you will likely need to grab the Result property that gives the list of input objects. Then, you will be able to replace these inputs by using one of the UpdateToX() methods of the ReplayHistoryResult. You should NOT use any document AddX() or ReplaceX() functions, as they will break history.

Syntax:
protected virtual bool ReplayHistory(
ReplayHistoryData replayData
)
protected
virtual
Parameters:
Returns:
Type: bool
True if the operation succeeded. The default implementation always returns false.

ReplayHistory method

Class:  Rhino.Commands.Command

Nothing found