Description:

Constructs a new instance of ColorHSV that is equivalent to an ARGB color.

Syntax:
public ColorHSV(
Color rgb
)
Parameters:
  • rgb
  • Type: System.Drawing.Color
  • ARGB color to mimic.
Remarks:
Exact conversions between color spaces are often not possible.
Available since:
6.0

Description:

Constructs a new instance of ColorHSV with custom channel values.

Syntax:
public ColorHSV(
double alpha,
double hue,
double saturation,
double value
)
Parameters:
  • alpha
  • Type: double
  • Alpha channel value. Channel will be limited to 0~1.
  • hue
  • Type: double
  • Hue channel value. Hue channels rotate between 0.0 and 1.0.
  • saturation
  • Type: double
  • Saturation channel value. Channel will be limited to 0~1.
  • value
  • Type: double
  • Value (Brightness) channel value. Channel will be limited to 0~1.
Available since:
6.0

Description:

Constructs a new instance of ColorHSV with custom channel values.

Syntax:
public ColorHSV(
double hue,
double saturation,
double value
)
Parameters:
  • hue
  • Type: double
  • Hue channel value. Hue channels rotate between 0.0 and 1.0.
  • saturation
  • Type: double
  • Saturation channel value. Channel will be limited to 0~1.
  • value
  • Type: double
  • Value (Brightness) channel value. Channel will be limited to 0~1.
Available since:
6.0

ColorHSV constructor

Class:  Rhino.Display.ColorHSV

Nothing found