Description:
Syntax:
public void Draw3dText(
string text,
Color color,
Plane textPlane,
double height,
string fontface,
bool bold,
bool italic,
TextHorizontalAlignment horizontalAlignment,
TextVerticalAlignment verticalAlignment
)
Returns:
Type: void
Available since:
6.4

Description:
Syntax:
public void Draw3dText(
string text,
Color color,
Plane textPlane,
double height,
string fontface,
bool bold,
bool italic
)
Returns:
Type: void
Available since:
6.0

Description:
Syntax:
public void Draw3dText(
string text,
Color color,
Plane textPlane,
double height,
string fontface
)
Returns:
Type: void
Available since:
5.0

Description:

Draws 3d text with a different plane than what is defined in the Text3d class.

Syntax:
public void Draw3dText(
Text3d text,
Color color,
Plane textPlane
)
Parameters:
  • text
  • Type: Text3d
  • The string to draw.
  • color
  • Type: System.Drawing.Color
  • Text color.
  • textPlane
  • Type: Plane
  • The plane for the text object.
Returns:
Type: void
Available since:
5.0

Description:

Draws 3d text using the Text3d plane with an adjusted origin.

Syntax:
public void Draw3dText(
Text3d text,
Color color,
Point3d textPlaneOrigin
)
Parameters:
  • text
  • Type: Text3d
  • The string to draw.
  • color
  • Type: System.Drawing.Color
  • Text color.
  • textPlaneOrigin
  • Type: Point3d
  • The origin of the plane to draw.
Returns:
Type: void
Available since:
5.0

Description:
Syntax:
public void Draw3dText(
Text3d text,
Color color
)
Returns:
Type: void
Available since:
5.0

Nothing found