menu
RhinoCommon API
search
search
V8
arrow_drop_down
new_releases
wb_sunny
RhinoCommon documentation has a new look. The old site can still be found
here
.
Close
Description:
Syntax:
public
void
DrawLine(
Line
line
,
DisplayPen
pen
)
Returns:
Type:
void
Available since:
8.0
Description:
Draws a single line object.
Syntax:
public
void
DrawLine(
Line
line
,
Color
color
,
int
thickness
)
Parameters:
line
Type:
Line
Line to draw.
color
Type:
System.Drawing.Color
Color to draw line in.
thickness
Type:
int
Thickness (in pixels) of line.
Returns:
Type:
void
Available since:
5.0
Description:
Draws a single line object.
Syntax:
public
void
DrawLine(
Line
line
,
Color
color
)
Parameters:
line
Type:
Line
Line to draw.
color
Type:
System.Drawing.Color
Color to draw line in.
Returns:
Type:
void
Available since:
5.0
Description:
Draws a single line object.
Syntax:
public
void
DrawLine(
Point3d
from
,
Point3d
to
,
Color
color
,
int
thickness
)
Parameters:
from
Type:
Point3d
Line from point.
to
Type:
Point3d
Line to point.
color
Type:
System.Drawing.Color
Color to draw line in.
thickness
Type:
int
Thickness (in pixels) of line.
Returns:
Type:
void
Available since:
5.0
Description:
Draws a single line object.
Syntax:
public
void
DrawLine(
Point3d
from
,
Point3d
to
,
Color
color
)
Parameters:
from
Type:
Point3d
Line from point.
to
Type:
Point3d
Line to point.
color
Type:
System.Drawing.Color
Color to draw line in.
Returns:
Type:
void
Available since:
5.0
home
/
Rhino.Display
/
DisplayPipeline
/
DrawLine
DrawLine method
Class:
Rhino.Display.DisplayPipeline
Nothing found