Description:

Draws an arrow marker as a view-aligned widget.

Syntax:
public void DrawMarker(
Point3d tip,
Vector3d direction,
Color color,
int thickness,
double size,
double rotation
)
Parameters:
  • tip
  • Type: Point3d
  • Location of arrow tip point.
  • direction
  • Type: Vector3d
  • Direction of arrow.
  • color
  • Type: System.Drawing.Color
  • Color of arrow widget.
  • thickness
  • Type: int
  • Thickness of arrow widget lines.
  • size
  • Type: double
  • Size (in pixels) of the arrow shaft.
  • rotation
  • Type: double
  • Rotational angle adjustment (in radians, counter-clockwise of direction.
Returns:
Type: void
Available since:
5.0

Description:

Draws an arrow marker as a view-aligned widget.

Syntax:
public void DrawMarker(
Point3d tip,
Vector3d direction,
Color color,
int thickness,
double size
)
Parameters:
  • tip
  • Type: Point3d
  • Location of arrow tip point.
  • direction
  • Type: Vector3d
  • Direction of arrow.
  • color
  • Type: System.Drawing.Color
  • Color of arrow widget.
  • thickness
  • Type: int
  • Thickness of arrow widget lines.
  • size
  • Type: double
  • Size (in pixels) of the arrow shaft.
Returns:
Type: void
Available since:
5.0

Description:

Draws an arrow marker as a view-aligned widget.

Syntax:
public void DrawMarker(
Point3d tip,
Vector3d direction,
Color color,
int thickness
)
Parameters:
  • tip
  • Type: Point3d
  • Location of arrow tip point.
  • direction
  • Type: Vector3d
  • Direction of arrow.
  • color
  • Type: System.Drawing.Color
  • Color of arrow widget.
  • thickness
  • Type: int
  • Thickness of arrow widget lines.
Returns:
Type: void
Available since:
5.0

Description:

Draws an arrow marker as a view-aligned widget.

Syntax:
public void DrawMarker(
Point3d tip,
Vector3d direction,
Color color
)
Parameters:
  • tip
  • Type: Point3d
  • Location of arrow tip point.
  • direction
  • Type: Vector3d
  • Direction of arrow.
  • color
  • Type: System.Drawing.Color
  • Color of arrow widget.
Returns:
Type: void
Available since:
5.0

Nothing found