Description:

Draws a point with a given radius, style and color.

Syntax:
public void DrawPoint(
Point3d point,
PointStyle style,
float radius,
Color color
)
Parameters:
  • point
  • Type: Point3d
  • Location of point in world coordinates.
  • radius
  • Type: float
  • Point size in pixels.
  • color
  • Type: System.Drawing.Color
  • Color of point. If style is ControlPoint, this will be the border color.
Returns:
Type: void
Available since:
6.0

Description:

Draws a point with a given radius, style and color.

Syntax:
public void DrawPoint(
Point3d point,
PointStyle style,
int radius,
Color color
)
Parameters:
  • point
  • Type: Point3d
  • Location of point in world coordinates.
  • radius
  • Type: int
  • Point size in pixels.
  • color
  • Type: System.Drawing.Color
  • Color of point. If style is ControlPoint, this will be the border color.
Returns:
Type: void
Available since:
5.0

Description:
Syntax:
public void DrawPoint(
Point3d point,
PointStyle style,
Color strokeColor,
Color fillColor,
float radius,
float strokeWidth,
float secondarySize,
float rotationRadians,
bool diameterIsInPixels,
bool autoScaleForDpi
)
Returns:
Type: void
Available since:
6.0

Description:

Draws a point with a given radius, style and color.

Syntax:
public void DrawPoint(
Point3d point,
Color color
)
Parameters:
  • point
  • Type: Point3d
  • Location of point in world coordinates.
  • color
  • Type: System.Drawing.Color
  • Color of point.
Returns:
Type: void
Available since:
5.0

Description:

Draws a point using the current display attribute size, style and color

Syntax:
public void DrawPoint(
Point3d point
)
Parameters:
  • point
  • Type: Point3d
  • Location of point in world coordinates.
Returns:
Type: void
Available since:
6.0

Nothing found