Description:

Test a given box for visibility inside the view frustum under the current viewport and model transformation settings.

Syntax:
public bool IsVisible(
BoundingBox bbox
)
Parameters:
Returns:
Type: bool
True if at least some portion of the box is visible, False if not.
Available since:
5.0

Description:

Test a given object for visibility inside the view frustum under the current viewport and model transformation settings. This function calls a virtual IsVisibleFinal function that sub-classed pipelines can add extra tests to. In the base class, this test only tests visibility based on the objects world coordinates location and does not pay attention to the object's attributes. NOTE: Use CRhinoDisplayPipeline::IsVisible() to perform "visibility" tests based on location (is some part of the object in the view frustum). Use CRhinoDisplayPipeline::IsActive() to perform "visibility" tests based on object type.

Syntax:
public bool IsVisible(
RhinoObject rhinoObject
)
Parameters:
Returns:
Type: bool
True if the object is visible, False if not.
Available since:
5.0

Description:

Test a given 3d world coordinate point for visibility inside the view frustum under the current viewport and model transformation settings.

Syntax:
public bool IsVisible(
Point3d worldCoordinate
)
Parameters:
  • worldCoordinate
  • Type: Point3d
  • Point to test for visibility.
Returns:
Type: bool
True if the point is visible, False if it is not.
Available since:
5.0

Nothing found