Description:
Sets up a display material.
Syntax:
public DisplayMaterial SetupDisplayMaterial(
RhinoDoc doc,
RhinoObject rhinoObject,
ObjectAttributes attributes,
Transform instanceTransform
)
RhinoDoc doc,
RhinoObject rhinoObject,
ObjectAttributes attributes,
Transform instanceTransform
)
Parameters:
- doc
- Type: RhinoDoc
- The active document.
- rhinoObject
- Type: RhinoObject
- The Rhino object.
- attributes
- Type: ObjectAttributes
- The object attributes.
- instanceTransform
- Type: Transform
- The instance object transformation.
Returns:
Type: DisplayMaterial
A display material if successful, None otherwise.
Available since:
8.0
Description:
Sets up a display material.
Syntax:
public DisplayMaterial SetupDisplayMaterial(
RhinoDoc doc,
RhinoObject rhinoObject,
ObjectAttributes attributes
)
RhinoDoc doc,
RhinoObject rhinoObject,
ObjectAttributes attributes
)
Parameters:
- doc
- Type: RhinoDoc
- The active document.
- rhinoObject
- Type: RhinoObject
- The Rhino object.
- attributes
- Type: ObjectAttributes
- The object attributes.
Returns:
Type: DisplayMaterial
A display material if successful, None otherwise.
Available since:
8.0
Description:
Sets up a display material.
Syntax:
Parameters:
- doc
- Type: RhinoDoc
- The active document.
- rhinoObject
- Type: RhinoObject
- The Rhino object.
Returns:
Type: DisplayMaterial
A display material if successful, None otherwise.
Available since:
8.0
Description:
Syntax: