Description:
Draws a NURBS surface. This is a good function to override to display object-related meshes. The default implementation does nothing.
Syntax:
protected virtual void DrawNurbsSurface(
RhinoObject obj,
NurbsSurface surface,
DisplayPipeline pipeline
)
RhinoObject obj,
NurbsSurface surface,
DisplayPipeline pipeline
)
protected
virtual
Parameters:
- obj
- Type: Rhino.DocObjects.RhinoObject
- A Rhino object corresponding to the surface.
- surface
- Type: Rhino.Geometry.NurbsSurface
- The surface geometry.
- pipeline
- Type: DisplayPipeline
- The current display pipeline.
Returns:
Type: void