Description:
Only for developers who are defining custom subclasses of CurveObject. Directly sets the internal curve geometry for this object. Note that this function does not work with Rhino's "undo".
protected
Returns:
Type: Curve
The old curve geometry that was set for this object
Remarks:
Note that this function does not work with Rhino's "undo". The typical approach for adjusting the curve geometry is to modify the object that you get when you call the CurveGeometry property and then call CommitChanges.