Description:

Moves the user data from objectWithUserData to a temporary data storage identified by the return Guid. When MoveUserDataFrom returns, the objectWithUserData will not have any user data.

Syntax:
public static Guid MoveUserDataFrom(
CommonObject objectWithUserData
)
Parameters:
Returns:
Type: Guid
Guid identifier for storage of UserData that is held in a temporary list by this class. This function should be used in conjunction with MoveUserDataTo to transfer the user data to a different object. Returns Guid.Empty if there was no user data to transfer.
Available since:
5.0

MoveUserDataFrom method

Class:  Rhino.DocObjects.Custom.UserData

Nothing found