Description:
Explodes the instance reference into pieces.
Syntax:
public void Explode(
bool explodeNestedInstances,
out RhinoObject[] pieces,
out ObjectAttributes[] pieceAttributes,
out Transform[] pieceTransforms
)
bool explodeNestedInstances,
out RhinoObject[] pieces,
out ObjectAttributes[] pieceAttributes,
out Transform[] pieceTransforms
)
Parameters:
- explodeNestedInstances
- Type: bool
- If true, then nested instance references are recursively exploded into pieces until actual geometry is found. If false, an InstanceObject is added to the pieces out parameter when this InstanceObject has nested references.
- pieces
- Type: RhinoObject[]
- An array of Rhino objects will be assigned to this out parameter during this call.
- pieceAttributes
- Type: ObjectAttributes[]
- An array of object attributes will be assigned to this out parameter during this call.
- pieceTransforms
- Type: Transform[]
- An array of the previously applied transform matrices will be assigned to this out parameter during this call.
Returns:
Type: void
Available since:
5.0
Description:
Explodes the instance reference into pieces.
Syntax:
public void Explode(
bool skipHiddenPieces,
Guid viewportId,
bool explodeNestedInstances,
out RhinoObject[] pieces,
out ObjectAttributes[] pieceAttributes,
out Transform[] pieceTransforms
)
bool skipHiddenPieces,
Guid viewportId,
bool explodeNestedInstances,
out RhinoObject[] pieces,
out ObjectAttributes[] pieceAttributes,
out Transform[] pieceTransforms
)
Parameters:
- skipHiddenPieces
- Type: bool
- If true, pieces that are not visible will not be appended to the pieces out parameter.
- viewportId
- Type: System.Guid
- If skipHiddenPieces is false, then viewportId is ignored. If bSkipHiddenPieces is True and and viewportId is not Guid.Empty, then layer and object per viewport visibility settings are used. If bSkipHiddenPieces is True and and viewport_id is Guid.Empty, then layer and object global visibility settings are used.
- explodeNestedInstances
- Type: bool
- If true, then nested instance references are recursively exploded into pieces until actual geometry is found. If false, an InstanceObject is added to the pieces out parameter when this InstanceObject has nested references.
- pieces
- Type: RhinoObject[]
- An array of Rhino objects will be assigned to this out parameter during this call.
- pieceAttributes
- Type: ObjectAttributes[]
- An array of object attributes will be assigned to this out parameter during this call.
- pieceTransforms
- Type: Transform[]
- An array of the previously applied transform matrices will be assigned to this out parameter during this call.
Returns:
Type: void
Available since:
8.9