Namespace: Rhino.DocObjectsReplayHistoryResult: references
ExistingObject
UpdateToAngularDimension(AngularDimension dimension, ObjectAttributes attributes)
UpdateToArc(Arc arc,ObjectAttributes attributes)
UpdateToBrep(Brep brep,ObjectAttributes attributes)
UpdateToCircle(Circle circle,ObjectAttributes attributes)
UpdateToClippingPlane(Plane plane, double uMagnitude, double vMagnitude, IEnumerable<Guid> clippedViewportIds, ObjectAttributes attributes)
UpdateToClippingPlane(Plane plane, double uMagnitude, double vMagnitude,Guid clippedViewportId, ObjectAttributes attributes)
UpdateToCurve(Curve curve,ObjectAttributes attributes)
UpdateToEllipse(Ellipse ellipse,ObjectAttributes attributes)
UpdateToExtrusion(Extrusion extrusion,ObjectAttributes attributes)
UpdateToHatch(Hatch hatch,ObjectAttributes attributes)
UpdateToInstanceReferenceGeometry(InstanceReferenceGeometry instanceReference,ObjectAttributes attributes)
UpdateToLeader(Leader leader,ObjectAttributes attributes)
UpdateToLine(Point3d from,Point3d to,ObjectAttributes attributes)
UpdateToLinearDimension(LinearDimension dimension, ObjectAttributes attributes)
UpdateToMesh(Mesh mesh,ObjectAttributes attributes)
UpdateToPoint(Point3d point, ObjectAttributes attributes)
UpdateToPointCloud(IEnumerable<Point3d> points,ObjectAttributes attributes)
UpdateToPointCloud(PointCloud cloud, ObjectAttributes attributes)
UpdateToPolyline(IEnumerable<Point3d> points,ObjectAttributes attributes)
UpdateToRadialDimension(RadialDimension dimension, ObjectAttributes attributes)
UpdateToSphere(Sphere sphere,ObjectAttributes attributes)
UpdateToSubD(SubD subD,ObjectAttributes attributes)
UpdateToSurface(Surface surface,ObjectAttributes attributes)
UpdateToText(TextEntity text,ObjectAttributes attributes)
UpdateToText(string text,Plane plane, double height, string fontName, bool bold, bool italic,TextJustification justification,ObjectAttributes attributes)
UpdateToTextDot(TextDot dot,ObjectAttributes attributes)