Description:
Called for every object that is associated with a snapshot and gets transformed in Rhino. This is getting called for each stored snapshot and gives the client the possibility to update the stored data.
Syntax:
public abstract bool ObjectTransformNotification(
RhinoDoc doc,
RhinoObject doc_object,
ref Transform transform,
BinaryArchiveReader archive
)
RhinoDoc doc,
RhinoObject doc_object,
ref Transform transform,
BinaryArchiveReader archive
)
Parameters:
- doc
- Type: RhinoDoc
- doc is the current document.
- doc_object
- Type: Rhino.DocObjects.RhinoObject
- doc_obj is the current object.
- transform
- Type: Rhino.Geometry.Transform
- transform is a transformation matrix. The matrix is set to identity the first time an object is associated with a snapshot. After that the matrix is updated when the object is transformed(scale, rotate etc.).
- archive
- Type: BinaryArchiveReader
- archive is a archive which can be used to update the stored data.
Returns:
Type: bool
True if successful, otherwise false.
Available since:
6.0