Description:
Called when the user restores a snapshot and SupportsObjects() and SupportsObject(Rhino.DocObjects.RhinoObject doc_object) returns true.
Syntax:
public abstract bool RestoreObject(
RhinoDoc doc,
RhinoObject doc_object,
ref Transform transform,
BinaryArchiveReader archive
)
RhinoDoc doc,
RhinoObject doc_object,
ref Transform transform,
BinaryArchiveReader archive
)
Parameters:
- doc
- Type: RhinoDoc
- doc is the current document.
- doc_object
- Type: Rhino.DocObjects.RhinoObject
- doc_obj is the current object.
- transform
- Type: Rhino.Geometry.Transform
- transform is a transformation matrix. The matrix is set to identity the first time an object is associated with a snapshot. After that the matrix is updated when the object is transformed(scale, rotate etc.).
- archive
- Type: BinaryArchiveReader
- archive is the archive to read the data from.
Returns:
Type: bool
True if successful, otherwise false.
Available since:
6.0