Description:

Deletes layers.

Syntax:
public int Delete(
IEnumerable<int> layerIndices,
bool quiet
)
Parameters:
  • layerIndices
  • Type: IEnumerable<int>
  • An enumeration containing the indices of the layers to delete.
  • quiet
  • Type: bool
  • If true, no warning message boxes will appear.
Returns:
Type: int
the number of layers that were deleted.
Available since:
8.0

Description:

Deletes layer.

Syntax:
public bool Delete(
int layerIndex,
bool quiet
)
Parameters:
  • layerIndex
  • Type: int
  • zero based index of layer to delete. This must be in the range 0 <= layerIndex < LayerTable.Count.
  • quiet
  • Type: bool
  • If true, no warning message box appears if a layer the layer cannot be deleted because it is the current layer or it contains active geometry.
Returns:
Type: bool
True if successful. False if layerIndex is out of range or the layer cannot be deleted because it is the current layer or because it layer contains active geometry.
Available since:
5.0

Description:

Deletes layer.

Syntax:
public bool Delete(
Layer layer,
bool quiet
)
Parameters:
  • layer
  • Type: Layer
  • Layer to be deleted.
  • quiet
  • Type: bool
  • If true, no warning message box appears if a layer the layer cannot be deleted because it is the current layer or it contains active geometry.
Returns:
Type: bool
True if successful. False if layerIndex is out of range or the layer cannot be deleted because it is the current layer or because it layer contains active geometry.
Available since:
6.0

Description:

Deletes layer.

Syntax:
public override bool Delete(
Layer layer
)
Parameters:
  • layer
  • Type: Layer
  • Layer to be deleted.
Returns:
Type: bool
True if successful. False if layerIndex is out of range or the layer cannot be deleted because it is the current layer or because it layer contains active geometry.
Available since:
6.0

Description:

Deletes layer.

Syntax:
public bool Delete(
Guid layerId,
bool quiet
)
Parameters:
  • layerId
  • Type: System.Guid
  • Id of the layer to be deleted.
  • quiet
  • Type: bool
  • If true, no warning message box appears if a layer the layer cannot be deleted because it is the current layer or it contains active geometry.
Returns:
Type: bool
True if successful. False if layerIndex is out of range or the layer cannot be deleted because it is the current layer or because it layer contains active geometry.
Available since:
6.0

Nothing found