Description:

Adds a box to the object table, as an extrusion.

Syntax:
public Guid AddBox(
Box box,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
Parameters:
  • box
  • Type: Box
  • The box.
  • attributes
  • Type: ObjectAttributes
  • Attributes that will be linked with the surface object.
  • reference
  • Type: bool
  • If a reference, object will not be saved in the document.
Returns:
Type: Guid
The ID.
Available since:
6.0

Description:

Adds a box to the object table.

Syntax:
public Guid AddBox(
Box box,
ObjectAttributes attributes
)
Parameters:
  • box
  • Type: Box
  • The box.
  • attributes
  • Type: ObjectAttributes
  • Attributes that will be linked with the surface object.
Returns:
Type: Guid
The ID.
Available since:
6.0

Description:

Adds a box to the object table.

Syntax:
public Guid AddBox(
Box box
)
Parameters:
  • box
  • Type: Box
  • The box.
Returns:
Type: Guid
The ID.
Available since:
6.0

Nothing found