Description:
Adds an ordinate dimension object to the document.
Syntax:
public Guid AddCentermark(
Centermark centermark,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
Centermark centermark,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
Parameters:
- centermark
- Type: Centermark
- Dimension object to add.
- attributes
- Type: ObjectAttributes
- Attributes to apply to dimension.
- history
- Type: HistoryRecord
- Object history to save.
- reference
- Type: bool
- If reference, then object will not be saved into the 3dm file.
Returns:
Type: Guid
The Guid of the newly added object or Guid.Empty on failure.
Available since:
6.0