Description:
Syntax:
public Guid AddClippingPlane(
Plane plane,
double uMagnitude,
double vMagnitude,
IEnumerable<Guid> clippedViewportIds,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
Plane plane,
double uMagnitude,
double vMagnitude,
IEnumerable<Guid> clippedViewportIds,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
Returns:
Type: Guid
Available since:
5.0
Description:
Adds a clipping plane object to Rhino.
Syntax:
public Guid AddClippingPlane(
Plane plane,
double uMagnitude,
double vMagnitude,
IEnumerable<Guid> clippedViewportIds,
ObjectAttributes attributes
)
Plane plane,
double uMagnitude,
double vMagnitude,
IEnumerable<Guid> clippedViewportIds,
ObjectAttributes attributes
)
Parameters:
- plane
- Type: Plane
- The plane value.
- uMagnitude
- Type: double
- The size in the U direction.
- vMagnitude
- Type: double
- The size in the V direction.
- clippedViewportIds
- Type: IEnumerable<Guid>
- A list, an array or any enumerable set of viewport IDs that the new clipping plane will clip.
- attributes
- Type: ObjectAttributes
- Document attributes for the plane.
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0
Description:
Adds a clipping plane object to Rhino.
Parameters:
- plane
- Type: Plane
- The plane value.
- uMagnitude
- Type: double
- The size in the U direction.
- vMagnitude
- Type: double
- The size in the V direction.
- clippedViewportIds
- Type: IEnumerable<Guid>
- A list, an array or any enumerable set of viewport IDs that the new clipping plane will clip.
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0
Description:
Syntax:
public Guid AddClippingPlane(
Plane plane,
double uMagnitude,
double vMagnitude,
Guid clippedViewportId,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
Plane plane,
double uMagnitude,
double vMagnitude,
Guid clippedViewportId,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
Returns:
Type: Guid
Available since:
5.0
Description:
Adds a clipping plane object to Rhino.
Parameters:
- plane
- Type: Plane
- The plane value.
- uMagnitude
- Type: double
- The size in the U direction.
- vMagnitude
- Type: double
- The size in the V direction.
- clippedViewportId
- Type: System.Guid
- Viewport ID that the new clipping plane will clip.
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0