Description:
Syntax:
public Guid AddExtrusion(
Extrusion extrusion,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
Returns:
Type: Guid
Available since:
5.0

Description:

Adds an extrusion object to Rhino.

Syntax:
public Guid AddExtrusion(
Extrusion extrusion,
ObjectAttributes attributes
)
Parameters:
  • extrusion
  • Type: Extrusion
  • A duplicate of this extrusion is added to Rhino.
  • attributes
  • Type: ObjectAttributes
  • Attributes that will be linked with the extrusion object.
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0

Description:

Adds an extrusion object to Rhino.

Syntax:
public Guid AddExtrusion(
Extrusion extrusion
)
Parameters:
  • extrusion
  • Type: Extrusion
  • A duplicate of this extrusion is added to Rhino.
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0

Nothing found