Description:
Syntax:
public Guid AddLeader(
IEnumerable<Point3d> points
)
Returns:
Type: Guid
Available since:
5.0

Description:

Adds a Leader object to the document.

Syntax:
public Guid AddLeader(
Leader leader,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
Parameters:
  • leader
  • Type: Leader
  • The leader object.
  • reference
  • Type: bool
  • If reference, then object will not be saved into the 3dm file.
Returns:
Type: Guid
The Guid of the newly added object or Guid.Empty on failure.
Available since:
6.0

Description:

Adds Leader object to the document.

Syntax:
public Guid AddLeader(
Leader leader,
ObjectAttributes attributes
)
Parameters:
  • leader
  • Type: Leader
  • The leader object.
Returns:
Type: Guid
The Guid of the newly added object or Guid.Empty on failure.
Available since:
6.0

Description:

Adds a Leader object to the document.

Syntax:
public Guid AddLeader(
Leader leader
)
Parameters:
  • leader
  • Type: Leader
  • The leader object.
Returns:
Type: Guid
The Id of the newly added object or Guid.Empty on failure.
Available since:
6.0

Description:
Syntax:
public Guid AddLeader(
Plane plane,
IEnumerable<Point2d> points,
ObjectAttributes attributes
)
Returns:
Type: Guid
Available since:
5.0

Description:
Syntax:
public Guid AddLeader(
Plane plane,
IEnumerable<Point2d> points
)
Returns:
Type: Guid
Available since:
5.0

Description:
Syntax:
public Guid AddLeader(
string text,
IEnumerable<Point3d> points
)
Returns:
Type: Guid
Available since:
5.0

Description:
Syntax:
public Guid AddLeader(
string text,
Plane plane,
IEnumerable<Point2d> points,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
Returns:
Type: Guid
Available since:
5.0

Description:
Syntax:
public Guid AddLeader(
string text,
Plane plane,
IEnumerable<Point2d> points,
ObjectAttributes attributes
)
Returns:
Type: Guid
Available since:
5.0

Description:
Syntax:
public Guid AddLeader(
string text,
Plane plane,
IEnumerable<Point2d> points
)
Returns:
Type: Guid
Available since:
5.0

Nothing found