Description:

Creates a PictureFrame object from a plane and a path to an image file, Note, a PictureFrame object is just a Plane surface or mesh that has a material with a texture assigned to it that displays in all display modes.

Syntax:
public Guid AddPictureFrame(
Plane plane,
string texturePath,
bool asMesh,
double width,
double height,
bool selfIllumination,
bool embedBitmap
)
Parameters:
  • plane
  • Type: Plane
  • Plane in which the PictureFrame will be created. Bottom left corner of picture will be at plane's origin, width will be in the plane's x axis direction, height will be in the plane's y axis direction.
  • texturePath
  • Type: string
  • path to an image file
  • asMesh
  • Type: bool
  • If true, the function will make a MeshObject rather than a surface
  • width
  • Type: double
  • Width of the resulting PictureFrame. If 0.0, the width of the picture frame is the width of the image if height is also 0.0 or calculated from the height and aspect ratio of the image if height is not 0.0.
  • height
  • Type: double
  • Height of the resulting PictureFrame. If 0.0, the height of the picture frame is the height of the image if width is also 0.0 or calculated from the width and aspect ratio of the image if width is not 0.0.
  • selfIllumination
  • Type: bool
  • If true, the image mapped to the picture frame plane always displays at full intensity and is not affected by light or shadow.
  • embedBitmap
  • Type: bool
  • If true, the function adds the image to the bitmap table of the document to which the PictureFrame will be added
Returns:
Type: Guid
A unique identifier for the object
Available since:
5.10

AddPictureFrame method

Class:  Rhino.DocObjects.Tables.ObjectTable

Nothing found