Description:
Syntax:
public Guid AddSurface(
Surface surface,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
Returns:
Type: Guid
Available since:
5.0

Description:

Adds a surface object to Rhino.

Syntax:
public Guid AddSurface(
Surface surface,
ObjectAttributes attributes
)
Parameters:
  • surface
  • Type: Surface
  • A duplicate of this surface is added to Rhino.
  • attributes
  • Type: ObjectAttributes
  • Attributes that will be linked with the surface object.
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0

Description:

Adds a surface object to Rhino.

Syntax:
public Guid AddSurface(
Surface surface
)
Parameters:
  • surface
  • Type: Surface
  • A duplicate of this surface is added to Rhino.
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0

Nothing found