Description:

Please use FindId().

Syntax:
public RhinoObject Find(
Guid objectId
)
Parameters:
  • objectId
  • Type: System.Guid
  • Do not use this method.
Returns:
Do not use this method.
Available since:
5.0

Description:

Use the object runtime serial number to find a rhino object in the document. This is the value stored on RhinoObject.RuntimeObjectSerialNumber. The RhinoObject constructor sets the runtime serial number and every instance of a RhinoObject class will have a unique serial number for the duration of the Rhino application. If an object is replaced with a new object, then the new object will have a different runtime serial number. Deleted objects stored in the undo list maintain their runtime serial numbers and this function will return pointers to these objects. Call RhinoObject.IsDeleted if you need to determine if the returned object is active or deleted. The runtime serial number is not saved in files.

Syntax:
public RhinoObject Find(
uint runtimeSerialNumber
)
Parameters:
  • runtimeSerialNumber
  • Type: uint
  • Runtime serial number to search for.
Returns:
Reference to the rhino object with the objectId or None if no such object could be found.
Available since:
5.0

Nothing found