Description:
Finds all objects whose UserString matches the search patterns.
Syntax:
public RhinoObject[] FindByUserString(
string key,
string value,
bool caseSensitive,
bool searchGeometry,
bool searchAttributes,
ObjectEnumeratorSettings filter
)
string key,
string value,
bool caseSensitive,
bool searchGeometry,
bool searchAttributes,
ObjectEnumeratorSettings filter
)
Parameters:
- key
- Type: string
- Search pattern for UserString keys (supported wildcards are: ? = any single character, * = any sequence of characters).
- value
- Type: string
- Search pattern for UserString values (supported wildcards are: ? = any single character, * = any sequence of characters).
- caseSensitive
- Type: bool
- If true, string comparison will be case sensitive.
- searchGeometry
- Type: bool
- If true, UserStrings attached to the geometry of an object will be searched.
- searchAttributes
- Type: bool
- If true, UserStrings attached to the attributes of an object will be searched.
- filter
- Type: ObjectEnumeratorSettings
- Rhino.DocObjects.ObjectEnumeratorSettings filter used to restrict the number of objects searched.
Returns:
Type: RhinoObject[]
An array of all objects whose UserString matches with the search patterns or None when no such objects could be found.
Available since:
5.0
Description:
Finds all objects whose UserString matches the search patterns.
Syntax:
public RhinoObject[] FindByUserString(
string key,
string value,
bool caseSensitive,
bool searchGeometry,
bool searchAttributes,
ObjectType filter
)
string key,
string value,
bool caseSensitive,
bool searchGeometry,
bool searchAttributes,
ObjectType filter
)
Parameters:
- key
- Type: string
- Search pattern for UserString keys (supported wildcards are: ? = any single character, * = any sequence of characters).
- value
- Type: string
- Search pattern for UserString values (supported wildcards are: ? = any single character, * = any sequence of characters).
- caseSensitive
- Type: bool
- If true, string comparison will be case sensitive.
- searchGeometry
- Type: bool
- If true, UserStrings attached to the geometry of an object will be searched.
- searchAttributes
- Type: bool
- If true, UserStrings attached to the attributes of an object will be searched.
- filter
- Type: ObjectType
- Object type filter.
Returns:
Type: RhinoObject[]
An array of all objects whose UserString matches with the search patterns or None when no such objects could be found.
Available since:
5.0
Description:
Finds all objects whose UserString matches the search patterns.
Syntax:
Parameters:
- key
- Type: string
- Search pattern for UserString keys (supported wildcards are: ? = any single character, * = any sequence of characters).
- value
- Type: string
- Search pattern for UserString values (supported wildcards are: ? = any single character, * = any sequence of characters).
- caseSensitive
- Type: bool
- If true, string comparison will be case sensitive.
Returns:
Type: RhinoObject[]
An array of all objects whose UserString matches with the search patterns or None when no such objects could be found.
Available since:
5.0