Description:

If objref.Object().IsNormal() is true, then the object will be hidden.

Syntax:
public bool Hide(
ObjRef objref,
bool ignoreLayerMode
)
Parameters:
  • objref
  • Type: ObjRef
  • reference to object to hide.
  • ignoreLayerMode
  • Type: bool
  • if true, the object will be hidden even if it is on a layer that is locked or off.
Returns:
Type: bool
True if the object was successfully hidden.
Available since:
5.0

Description:

If obj.IsNormal() is true, then the object will be hidden.

Syntax:
public bool Hide(
RhinoObject obj,
bool ignoreLayerMode
)
Parameters:
  • ignoreLayerMode
  • Type: bool
  • if true, the object will be hidden even if it is on a layer that is locked or off.
Returns:
Type: bool
True if the object was successfully hidden.
Available since:
5.0

Description:

If Object().IsNormal() is true, then the object will be hidden.

Syntax:
public bool Hide(
Guid objectId,
bool ignoreLayerMode
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of object to hide.
  • ignoreLayerMode
  • Type: bool
  • if true, the object will be hidden even if it is on a layer that is locked or off.
Returns:
Type: bool
True if the object was successfully hidden.
Available since:
5.0

Nothing found