Description:

If objref.Object().IsNormal() is true, then the object will be locked.

Syntax:
public bool Lock(
ObjRef objref,
bool ignoreLayerMode
)
Parameters:
  • objref
  • Type: ObjRef
  • reference to normal object to lock.
  • ignoreLayerMode
  • Type: bool
  • if true, the object will be locked even if it is on a layer that is locked or off.
Returns:
Type: bool
True if the object was successfully locked.
Available since:
5.0

Description:

If obj.IsNormal() is true, then the object will be locked.

Syntax:
public bool Lock(
RhinoObject obj,
bool ignoreLayerMode
)
Parameters:
  • ignoreLayerMode
  • Type: bool
  • if true, the object will be locked even if it is on a layer that is locked or off.
Returns:
Type: bool
True if the object was successfully locked.
Available since:
5.0

Description:

If objref.Object().IsNormal() is true, then the object will be locked.

Syntax:
public bool Lock(
Guid objectId,
bool ignoreLayerMode
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of normal object to lock.
  • ignoreLayerMode
  • Type: bool
  • if true, the object will be locked even if it is on a layer that is locked or off.
Returns:
Type: bool
True if the object was successfully locked.
Available since:
5.0

Nothing found