Description:

If objref.Object().IsLocked() is true, then the object will be returned to normal (visible and selectable) mode.

Syntax:
public bool Unlock(
ObjRef objref,
bool ignoreLayerMode
)
Parameters:
  • objref
  • Type: ObjRef
  • reference to locked object to unlock.
  • ignoreLayerMode
  • Type: bool
  • if true, the object will be unlocked even if it is on a layer that is locked or off.
Returns:
Type: bool
True if the object was successfully unlocked.
Available since:
5.0

Description:

If obj.IsLocked() is true, then the object will be returned to normal (visible and selectable) mode.

Syntax:
public bool Unlock(
RhinoObject obj,
bool ignoreLayerMode
)
Parameters:
  • ignoreLayerMode
  • Type: bool
  • if true, the object will be unlocked even if it is on a layer that is locked or off.
Returns:
Type: bool
True if the object was successfully unlocked.
Available since:
5.0

Description:

If Object().IsLocked() is true, then the object will be returned to normal (visible and selectable) mode.

Syntax:
public bool Unlock(
Guid objectId,
bool ignoreLayerMode
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of locked object to unlock.
  • ignoreLayerMode
  • Type: bool
  • if true, the object will be unlocked even if it is on a layer that is locked or off.
Returns:
Type: bool
True if the object was successfully unlocked.
Available since:
5.0

Nothing found