Description:

Finds a view in this document with a main viewport that has a given name. Note that there may be multiple views in this document that have the same name. This function only returns the first view found. If you want to find all the views with a given name, use the GetViewList function and iterate through the views.

Syntax:
public RhinoView Find(
string mainViewportName,
bool compareCase
)
Parameters:
  • mainViewportName
  • Type: string
  • The name of the main viewport.
  • compareCase
  • Type: bool
  • True if capitalization influences comparison; otherwise, false.
Returns:
Type: RhinoView
A Rhino view on success; None on error.
Available since:
5.0

Description:

Finds a view in this document with a given main viewport Id.

Syntax:
public RhinoView Find(
Guid mainViewportId
)
Parameters:
  • mainViewportId
  • Type: System.Guid
  • The ID of the main viewport looked for.
Returns:
Type: RhinoView
View on success. None if the view could not be found in this document.
Available since:
5.0

Nothing found