Description:

Writes contents of this model to an openNURBS archive. If the model is not valid, then Write will refuse to write it.

Syntax:
public bool Write(
string path,
File3dmWriteOptions options
)
Parameters:
  • path
  • Type: string
  • The file name to use for writing.
Returns:
Type: bool
True if archive is written with no error. False if errors occur.
Available since:
5.9

Description:

Writes contents of this model to an openNURBS archive. If the model is not valid, then Write will refuse to write it.

Syntax:
public bool Write(
string path,
int version
)
Parameters:
  • path
  • Type: string
  • The file name to use for writing.
  • version
  • Type: int
  • Version of the openNURBS archive to write. Must be [2; current version]. Rhino can read its current version, plus earlier file versions except 1. Use latest version when possible. Alternatively, 0 is a placeholder for the last valid version.
Returns:
Type: bool
True if archive is written with no error. False if errors occur.
Available since:
5.0

Write method

Class:  Rhino.FileIO.File3dm

Nothing found