Description:

Creates a brep representation of the sphere with two similar trimmed NURBS surfaces, and no singularities.

Syntax:
public static Brep CreateBaseballSphere(
Point3d center,
double radius,
double tolerance
)
Parameters:
  • center
  • Type: Point3d
  • The center of the sphere.
  • radius
  • Type: double
  • The radius of the sphere.
  • tolerance
  • Type: double
  • Used in computing 2d trimming curves. If >= 0.0, then the max of ON_0.0001 * radius and RhinoMath.ZeroTolerance will be used.
Returns:
Type: Brep
A new brep, or None on error.
Available since:
6.0

/
/
/
CreateBaseballSphere

CreateBaseballSphere method

Class:  Rhino.Geometry.Brep

Nothing found