Description:

Compute the Solid Difference of two Breps.

Syntax:
public static Brep[] CreateBooleanDifference(
Brep firstBrep,
Brep secondBrep,
double tolerance,
bool manifoldOnly
)
Parameters:
  • firstBrep
  • Type: Brep
  • First Brep for boolean difference.
  • secondBrep
  • Type: Brep
  • Second Brep for boolean difference.
  • tolerance
  • Type: double
  • Tolerance to use for difference operation.
  • manifoldOnly
  • Type: bool
  • If true, non-manifold input breps are ignored.
Returns:
Type: Brep[]
An array of Brep results or None on failure.
Remarks:
The solid orientation of the breps make a difference when calling this function
Available since:
6.0

Description:

Compute the Solid Difference of two Breps.

Syntax:
public static Brep[] CreateBooleanDifference(
Brep firstBrep,
Brep secondBrep,
double tolerance
)
Parameters:
  • firstBrep
  • Type: Brep
  • First Brep for boolean difference.
  • secondBrep
  • Type: Brep
  • Second Brep for boolean difference.
  • tolerance
  • Type: double
  • Tolerance to use for difference operation.
Returns:
Type: Brep[]
An array of Brep results or None on failure.
Remarks:
The solid orientation of the breps make a difference when calling this function
Available since:
5.0

Description:

Compute the Solid Difference of two sets of Breps.

Syntax:
public static Brep[] CreateBooleanDifference(
IEnumerable<Brep> firstSet,
IEnumerable<Brep> secondSet,
double tolerance,
bool manifoldOnly
)
Parameters:
  • firstSet
  • Type: IEnumerable<Brep>
  • First set of Breps (the set to subtract from).
  • secondSet
  • Type: IEnumerable<Brep>
  • Second set of Breps (the set to subtract).
  • tolerance
  • Type: double
  • Tolerance to use for difference operation.
  • manifoldOnly
  • Type: bool
  • If true, non-manifold input breps are ignored.
Returns:
Type: Brep[]
An array of Brep results or None on failure.
Remarks:
The solid orientation of the breps make a difference when calling this function
Available since:
6.0

Description:

Compute the Solid Difference of two sets of Breps.

Syntax:
public static Brep[] CreateBooleanDifference(
IEnumerable<Brep> firstSet,
IEnumerable<Brep> secondSet,
double tolerance
)
Parameters:
  • firstSet
  • Type: IEnumerable<Brep>
  • First set of Breps (the set to subtract from).
  • secondSet
  • Type: IEnumerable<Brep>
  • Second set of Breps (the set to subtract).
  • tolerance
  • Type: double
  • Tolerance to use for difference operation.
Returns:
Type: Brep[]
An array of Brep results or None on failure.
Remarks:
The solid orientation of the breps make a difference when calling this function
Available since:
5.0

/
/
/
CreateBooleanDifference

CreateBooleanDifference method

Class:  Rhino.Geometry.Brep

Nothing found