Description:

Compute the solid difference between two sets of Breps.

Syntax:
public static Brep[] CreateBooleanDifferenceWithIndexMap(
IEnumerable<Brep> firstSet,
IEnumerable<Brep> secondSet,
double tolerance,
bool manifoldOnly,
out int indexMap
)
Parameters:
  • firstSet
  • Type: IEnumerable<Brep>
  • The set to be differenced from.
  • secondSet
  • Type: IEnumerable<Brep>
  • The set to difference with.
  • tolerance
  • Type: double
  • Tolerance to use for the boolean operation.
  • manifoldOnly
  • Type: bool
  • If true, non-manifold input breps are ignored.
  • indexMap
  • Type: int
  • results[i] is the result if subtracting something from firstSet[indexMap[i]].
Returns:
Type: Brep[]
An array of Brep results or None on failure. May be empty if all of the firstSet is differenced away.
Available since:
8.13

/
/
/
CreateBooleanDifferenceWithIndexMap

CreateBooleanDifferenceWithIndexMap method

Class:  Rhino.Geometry.Brep

Nothing found