Description:

Splits shared areas of Breps and creates separate Breps from the shared and unshared parts.

Syntax:
public static Brep[] CreateBooleanSplit(
Brep firstBrep,
Brep secondBrep,
double tolerance
)
Parameters:
  • firstBrep
  • Type: Brep
  • The Brep to split.
  • secondBrep
  • Type: Brep
  • The cutting Brep.
  • tolerance
  • Type: double
  • Tolerance to use for splitting operation. When in doubt, use the document's model absolute tolerance.
Returns:
Type: Brep[]
An array of Brep if successful, an empty array on failure.
Available since:
6.16

Description:

Splits shared areas of Breps and creates separate Breps from the shared and unshared parts.

Syntax:
public static Brep[] CreateBooleanSplit(
IEnumerable<Brep> firstSet,
IEnumerable<Brep> secondSet,
double tolerance
)
Parameters:
  • firstSet
  • Type: IEnumerable<Brep>
  • The Breps to split.
  • secondSet
  • Type: IEnumerable<Brep>
  • The cutting Breps.
  • tolerance
  • Type: double
  • Tolerance to use for splitting operation. When in doubt, use the document's model absolute tolerance.
Returns:
Type: Brep[]
An array of Brep if successful, an empty array on failure.
Available since:
6.16

/
/
/
CreateBooleanSplit

CreateBooleanSplit method

Class:  Rhino.Geometry.Brep

Nothing found