Description:

Fillets, chamfers, or blends the edges of a brep.

Syntax:
public static Brep[] CreateFilletEdges(
Brep brep,
IEnumerable<int> edgeIndices,
IEnumerable<double> startRadii,
IEnumerable<double> endRadii,
BlendType blendType,
RailType railType,
bool setbackFillets,
double tolerance,
double angleTolerance
)
Parameters:
  • brep
  • Type: Brep
  • The brep to fillet, chamfer, or blend edges.
  • edgeIndices
  • Type: IEnumerable<int>
  • An array of one or more edge indices where the fillet, chamfer, or blend will occur.
  • startRadii
  • Type: IEnumerable<double>
  • An array of starting fillet, chamfer, or blend radaii, one for each edge index.
  • endRadii
  • Type: IEnumerable<double>
  • An array of ending fillet, chamfer, or blend radaii, one for each edge index.
  • setbackFillets
  • Type: bool
  • UJse setback fillets (only used with blendType= BlendType.Blend )
  • tolerance
  • Type: double
  • The tolerance to be used to perform calculations.
  • angleTolerance
  • Type: double
  • Angle tolerance to be used to perform calculations [radians].
Returns:
Type: Brep[]
Array of Breps if successful.
Available since:
8.6

Description:

Fillets, chamfers, or blends the edges of a brep.

Syntax:
public static Brep[] CreateFilletEdges(
Brep brep,
IEnumerable<int> edgeIndices,
IEnumerable<double> startRadii,
IEnumerable<double> endRadii,
BlendType blendType,
RailType railType,
double tolerance
)
Parameters:
  • brep
  • Type: Brep
  • The brep to fillet, chamfer, or blend edges.
  • edgeIndices
  • Type: IEnumerable<int>
  • An array of one or more edge indices where the fillet, chamfer, or blend will occur.
  • startRadii
  • Type: IEnumerable<double>
  • An array of starting fillet, chamfer, or blend radaii, one for each edge index.
  • endRadii
  • Type: IEnumerable<double>
  • An array of ending fillet, chamfer, or blend radaii, one for each edge index.
  • tolerance
  • Type: double
  • The tolerance to be used to perform calculations.
Returns:
Type: Brep[]
Array of Breps if successful.
Available since:
6.0

/
/
/
CreateFilletEdges

CreateFilletEdges method

Class:  Rhino.Geometry.Brep

Nothing found