Description:

Fillets, chamfers, or blends the edges of a brep.

Syntax:
public static Brep[] CreateFilletEdgesVariableRadius(
Brep brep,
IEnumerable<int> edgeIndices,
IDictionary<int, IList<BrepEdgeFilletDistance>> edgeDistances,
BlendType blendType,
RailType railType,
bool setbackFillets,
double tolerance,
double angleTolerance
)
Parameters:
  • brep
  • Type: Brep
  • The brep to fillet, chamfer, or blend edges.
  • edgeIndices
  • Type: IEnumerable<int>
  • An array of one or more edge indices where the fillet, chamfer, or blend will occur.
  • edgeDistances
  • Type: IDictionary<int, IList<BrepEdgeFilletDistance>>
  • A dictionary with key the edge index on the input brep, and value a list of BrepEdgeFilletDistance items to apply.
  • setbackFillets
  • Type: bool
  • UJse setback fillets (only used with blendType= BlendType.Blend )
  • tolerance
  • Type: double
  • The tolerance to be used to perform calculations.
  • angleTolerance
  • Type: double
  • Angle tolerance to be used to perform calculations [radians].
Returns:
Type: Brep[]
Array of Breps if successful.
Available since:
8.6

/
/
/
CreateFilletEdgesVariableRadius

CreateFilletEdgesVariableRadius method

Class:  Rhino.Geometry.Brep

Nothing found