Description:

Constructs new brep that matches a bounding box.

Syntax:
public static Brep CreateFromBox(
BoundingBox box
)
Parameters:
Returns:
Type: Brep
A new brep; or None on failure.
Available since:
5.0

Description:

Constructs new brep that matches an aligned box.

Syntax:
public static Brep CreateFromBox(
Box box
)
Parameters:
  • box
  • Type: Box
  • Box to match.
Returns:
Type: Brep
A Brep with 6 faces that is similar to the Box.
Available since:
5.0

Description:

Constructs new brep from 8 corner points.

Syntax:
public static Brep CreateFromBox(
IEnumerable<Point3d> corners
)
Parameters:
  • corners
  • Type: IEnumerable<Point3d>
  • 8 points defining the box corners arranged as the vN labels indicate.
    v7_______e6____v6  
    |\             |\  
    | e7           | e5  
    |  \ ______e4_____\  
    e11 v4         |   v5  
    |   |        e10   |  
    |   |          |   |  
    v3--|---e2----v2   e9  
     \  e8          \  |  
     e3 |            e1|  
       \|             \|  
        v0_____e0______v1
Returns:
Type: Brep
A new brep, or None on error.
Available since:
5.0

/
/
/
CreateFromBox

CreateFromBox method

Class:  Rhino.Geometry.Brep

Nothing found