Description:

Makes a Brep with one face from three corner points.

Syntax:
public static Brep CreateFromCornerPoints(
Point3d corner1,
Point3d corner2,
Point3d corner3,
double tolerance
)
Parameters:
  • corner1
  • Type: Point3d
  • A first corner.
  • corner2
  • Type: Point3d
  • A second corner.
  • corner3
  • Type: Point3d
  • A third corner.
  • tolerance
  • Type: double
  • Minimum edge length allowed before collapsing the side into a singularity.
Returns:
Type: Brep
A boundary representation, or None on error.
Available since:
5.0

Description:

Makes a Brep with one face from four corner points.

Syntax:
public static Brep CreateFromCornerPoints(
Point3d corner1,
Point3d corner2,
Point3d corner3,
Point3d corner4,
double tolerance
)
Parameters:
  • corner1
  • Type: Point3d
  • A first corner.
  • corner2
  • Type: Point3d
  • A second corner.
  • corner3
  • Type: Point3d
  • A third corner.
  • corner4
  • Type: Point3d
  • A fourth corner.
  • tolerance
  • Type: double
  • Minimum edge length allowed before collapsing the side into a singularity.
Returns:
Type: Brep
A boundary representation, or None on error.
Available since:
5.0

/
/
/
CreateFromCornerPoints

CreateFromCornerPoints method

Class:  Rhino.Geometry.Brep

Nothing found